summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVaporeon2022-07-01 20:39:48 +1200
committerVaporeon2022-07-01 20:39:48 +1200
commitb9e0ab9bdceafcd21763e9a1d5d2092f820d4238 (patch)
tree4d99ab022761715dfd8b4b6eed86310963310a38 /PKGBUILD
parentc90efbd3239b19ab5b5dec1de4326e818a105d13 (diff)
downloadaur-b9e0ab9bdceafcd21763e9a1d5d2092f820d4238.tar.gz
Fix build with current sameboy source.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e76a876f14d3..c2957a72c4fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vaporeon <vaporeon@vaporeon.io>
pkgname=superdux-git
-pkgver=0.1.0.r359.d1cadf5+r1866.8f8b7f6b
+pkgver=0.1.0.r359.d1cadf5+r1875.1b38e8c9
pkgrel=1
pkgdesc="A Qt-based interface of SameBoy, An accuracy-focused Game Boy/Game Boy Color emulator (git build)"
depends=('qt6-base')
@@ -10,9 +10,11 @@ arch=('x86_64')
url="https://github.com/SnowyMouse/superdux"
license=('GPL3')
source=("git+https://github.com/SnowyMouse/${pkgname%-git}.git"
- "git+https://github.com/LIJI32/SameBoy.git")
+ "git+https://github.com/LIJI32/SameBoy.git"
+ 'fix_on_vblank_args.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'bc7795e263452d7e215986fd11e6aa47f967cdb7acce5b9e2c7de5e5e66e553a')
provides=('superdux')
conflicts=('superdux')
@@ -26,6 +28,8 @@ pkgver() {
prepare() {
mkdir -p build
+ cd ${pkgname%-git}
+ patch -Np1 <../fix_on_vblank_args.patch
}
build() {
@@ -33,11 +37,11 @@ build() {
cmake ../${pkgname%-git} -G Ninja \
-DSAMEBOY_SOURCE_DIR="${srcdir}"/SameBoy \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
ninja
}
package() {
- cd "$srcdir"/build
+ cd "${srcdir}"/build
ninja install
}