summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2020-07-03 14:59:48 -0400
committerTed Alff2020-07-03 14:59:48 -0400
commite6702c2ad81b8628b3c51a3da88e3cfb9583dcc9 (patch)
tree4a7b7b99042f6477a4a57cda2bd5fe7f02c92a11 /PKGBUILD
parente4a4bf18dcd9650b6d92e0c6d8dd5b5b3276466a (diff)
downloadaur-e6702c2ad81b8628b3c51a3da88e3cfb9583dcc9.tar.gz
Remove patch that reverted the pillow 7.0+ requiremenet now that it's in the repos.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8035ec97776c..fcd90d0886d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,17 @@
pkgname=superpaper
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-platform multi monitor wallpaper manager"
arch=('any')
url="https://github.com/hhannine/Superpaper"
license=('MIT')
-depends=('python-pillow' 'python-screeninfo>=0.6.1' 'python-wxpython'
+depends=('python-pillow>=7.0' 'python-screeninfo>=0.6.1' 'python-wxpython'
'python-system_hotkey>=1.0.2+10+9541587' 'python-xpybutil' 'python-numpy')
makedepends=('python-distutils-extra')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz"
- '0001_revert_pillow_7.0_requirement.patch')
-sha256sums=('58b5c7f79d772142c819b00f4925193bc135fa29312d933b3a7cd8adcad9f56c'
- '0e00a061c96564310c42f8a18b8a2f67ac44a31544f1f48d496445f78b6f3530')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz")
+sha256sums=('58b5c7f79d772142c819b00f4925193bc135fa29312d933b3a7cd8adcad9f56c')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # Revert image optimizations which bumped the Pillow dep to 7.0+
- # until Arch updates the python-pillow package.
- patch -Np2 -r- -i ../0001_revert_pillow_7.0_requirement.patch
-}
-
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root "${pkgdir}" --optimize=1