summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas1818.de2020-06-10 23:48:10 +0200
committerLukas1818.de2020-06-10 23:48:10 +0200
commit1d1835ec4d124dd93627ca457f5facdd774ae5c9 (patch)
tree15cbe12756673dfcb3382476ad5e3291d8ccdc76 /PKGBUILD
parent89250498e9b4eba97e6bf4ce932166350ff53e59 (diff)
downloadaur-1d1835ec4d124dd93627ca457f5facdd774ae5c9.tar.gz
change to SuperSlicer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66232e7df6a4..c715571a60cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,40 @@
-# Maintainer: Dominic Meiser git at msrd0 dot de
+# Maintainer: Lukas1818 aur at lukas1818 dot de
-pkgname=slic3r++
-pkgver=2.2.50
+pkgname=superslicer
+pkgver=2.2.51
_pkgtag=$pkgver
pkgrel=1
pkgdesc="G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)"
arch=('x86_64')
-url="https://github.com/supermerill/Slic3r"
+url="https://github.com/supermerill/SuperSlicer"
license=('AGPL3')
depends=('cgal' 'glew' 'nlopt' 'openvdb' 'qhull' 'wxgtk3')
+conflicts=('slic3r++')
makedepends=('boost' 'cereal' 'cmake' 'eigen' 'libigl' 'openvdb' 'wxgtk2') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
-source=("https://github.com/supermerill/Slic3r/archive/$_pkgtag.tar.gz"
- "slic3r++.desktop"
+source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
+ "superslicer.desktop"
"0001-wxgtk3-is-broken-on-wayland.patch")
-sha512sums=('f84a37dcaec2a5e24e197572b08ccb3c9cd17d9c048f2e0af0ad52d1b928b11f1447445f6e97b27e2b28e1c51c9666dcfae1f38986d9d5109e10a02d83ea8303'
- '2f9e364724e28e26c328b83cbf76c6d05544469c3ae14324ae11a1c97fc11878d1f892674ddc6440d14d8bfbca80ba8fc0dcbaa7cf3b7420e91962ee9582b8a2'
+sha512sums=('12dd8669d716367674e8004bbbc3781489c7c97868b103497c4f88827c0054746b5e46835cd2af63af87f726080009cb7570d0554200e78e303835a79787dd87'
+ '18b39d66b12453686ac0b411bac4a7c3000c541aeb0de2cacf37552a0e2435858c9ce2d3da10fa05ab6ab0e5e714f78f6a011f894435ab7195ae5f3ed8bc5623'
'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5')
prepare()
{
- cd "$srcdir/Slic3r-$_pkgtag"
-
+ cd "$srcdir/SuperSlicer-$_pkgtag"
+
# disabling tests is not enough, we need to remove them explicitly
sed -i 's,add_subdirectory(test),,g' src/CMakeLists.txt
-
+
# apply patches
patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch"
}
build()
{
- cd "$srcdir/Slic3r-$_pkgtag"
+ cd "$srcdir/SuperSlicer-$_pkgtag"
mkdir -p build
cd build
-
+
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -48,11 +49,11 @@ build()
package()
{
- cd "$srcdir/Slic3r-$_pkgtag/build"
-
+ cd "$srcdir/SuperSlicer-$_pkgtag/build"
+
make DESTDIR="$pkgdir" install
test ! -h "$pkgdir/usr/share/slic3r++/resources" || rm "$pkgdir/usr/share/slic3r++/resources"
-
+
install -d "$pkgdir/usr/share/applications"
- install -m 644 "$srcdir/slic3r++.desktop" "$pkgdir/usr/share/applications/"
+ install -m 644 "$srcdir/superslicer.desktop" "$pkgdir/usr/share/applications/"
}