summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas18182020-12-31 15:55:52 +0100
committerLukas18182020-12-31 15:55:52 +0100
commita0a631cdb237848ba40953aa51140217d160acba (patch)
treed0eb7dd97b000136210582f130379a2086d000c7 /PKGBUILD
parent58885d430834e104ec3b35a3566d5ac8c1541961 (diff)
downloadaur-a0a631cdb237848ba40953aa51140217d160acba.tar.gz
change back to the official boost package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a05f133a57c6..fa5e09bd565a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,24 @@
pkgname=superslicer
pkgver=2.2.54.2
_pkgtag=$pkgver
-pkgrel=2
+pkgrel=3
pkgdesc="G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)"
arch=('x86_64')
url="https://github.com/supermerill/SuperSlicer"
license=('AGPL3')
-depends=('cgal' 'glew' 'nlopt' 'openvdb' 'wxgtk3-dev-opt' 'boost-libs-171-opt' 'qhull>=2020.2-4')
+depends=('cgal' 'glew' 'nlopt' 'openvdb' 'wxgtk3-dev-opt' 'boost>=1.73.0' 'qhull>=2020.2-4')
replaces=('slic3r++')
makedepends=('cereal' 'cmake' 'eigen' 'libigl' 'openvdb' 'wxgtk2-dev-opt') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
"superslicer.desktop"
"start-superslicer.sh"
- "0001-wxgtk3-is-broken-on-wayland.patch")
+ "0001-wxgtk3-is-broken-on-wayland.patch"
+ "0001-Replace-deprecated-Boost-header-in-admesh.patch")
sha512sums=('3e28d28f463be49217d4aa19691bd190d644f86474786db69ec82d58090d2231a6c0add66eec59ac9f8c2169bfcd730a0c9deafd9df48182e92194bf6d2f39b6'
'8f75de56ba3e29b9c650d2946bd11afcf406a7fd42d2620ec44e4e76f6b64626de720190ce0f8be29ba7c48f714bfa0a71c45f868bdce7bc1ac7dbbc0e9e7583'
- '3703901d97ae1982a36eb5c491fe0fd6953e81e6bb1d155404acfcac1de1f377931c88b9667688775af5ed16bd46944ca3a285bc4b2739762faa70e546044c43'
- 'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5')
+ 'abfbd056be518b1b733cddef6c430cc3c4199d5df13067574dd3269cf35b798e11b43f55f1dfb57d6d8ee1da06882825fef0f7a170a9b069b95e9aea1ec8f31d'
+ 'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5'
+ '9a860dbac69ca7a195ef43cb2b80a8b5cf2c34bddb91867aa8ba16bbb754ab68c4baf57fa7e2562f96facc435c64ed8445505edb152382dbc5106a509136a2c8')
prepare()
{
@@ -29,6 +31,7 @@ prepare()
# apply patches
patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch"
+ patch --forward --strip=1 --input="$srcdir/0001-Replace-deprecated-Boost-header-in-admesh.patch"
}
build()
@@ -46,11 +49,6 @@ build()
-DSLIC3R_WX_STABLE=ON \
-DSLIC3R_GTK=3 \
-DSLIC3R_BUILD_TESTS=OFF \
- -DBoost_NO_BOOST_CMAKE=TRUE \
- -DBoost_NO_SYSTEM_PATHS=TRUE \
- -DBOOST_ROOT:PATHNAME=/opt/usr \
- -DBoost_LIBRARY_DIRS:FILEPATH=/opt/usr/lib \
- -DBoost_INCLUDE_DIR:FILEPATH=/opt/usr/include \
-DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config
make