summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2018-06-03 11:37:07 +0200
committerFrederic Bezies2018-06-03 11:37:07 +0200
commitbde02f2ad61299e816e2e69362b20921cca03272 (patch)
treecd725eb80b1422aafd0ca9ae6b75bec045cc0ec1 /PKGBUILD
parentd529e3d346e5a739168cb24d38f4c9a8108f7cef (diff)
downloadaur-bde02f2ad61299e816e2e69362b20921cca03272.tar.gz
updated and cleaned up PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 5 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3282ee3173b8..12921f7ae7ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=supertux-git
_pkgname=supertux
-pkgver=v0.5.1.r423.gcd4bdbf70
+pkgver=v0.5.1.r457.g7430e289e
pkgrel=1
epoch=1
pkgdesc="A classic 2D jump'n run sidescroller game in a style similar to the original SuperMario game"
@@ -16,24 +16,9 @@ depends=('sdl2_image' 'openal' 'libvorbis' 'glew' 'boost-libs' 'curl')
makedepends=('git' 'cmake' 'physfs' 'boost')
conflicts=(supertux)
provides=(supertux)
-source=('git+https://github.com/SuperTux/supertux.git'
- # submodules
- 'git+https://github.com/SuperTux/data.git'
- 'git+https://github.com/google/googletest.git'
- 'git+https://github.com/SuperTux/physfs.git'
- 'git+https://github.com/SuperTux/sexp-cpp.git'
- 'git+https://github.com/albertodemichelis/squirrel.git'
- 'git+https://github.com/SuperTux/tinygettext.git'
- 'git+https://github.com/SuperTux/translations.git')
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
-
+source=('git+https://github.com/SuperTux/supertux.git')
+sha512sums=('SKIP')
+
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -42,15 +27,7 @@ pkgver() {
prepare() {
cd "$_pkgname"
- git submodule init
- git config submodule.data.url "${srcdir}"/data
- git config submodule.external/googletest.url "${srcdir}"/googletest
- git config submodule.external/physfs.url "${srcdir}"/physfs
- git config submodule.external/sexp-cpp.url "${srcdir}"/sexp-cpp
- git config submodule.external/squirrel.url "${srcdir}"/squirrel
- git config submodule.external/tinygettext.url "${srcdir}"/tinygettext
- git config submodule.translations.url "${srcdir}"/translations
- git submodule update
+ git submodule update --init --recursive
sed -i '/curl\/types.h/d' src/addon/addon_manager.cpp
sed -i '1i#include <cstddef>' src/supertux/screen_manager.hpp