summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRandoragon2021-01-24 15:01:42 +0100
committerRandoragon2021-01-24 15:01:42 +0100
commitc7e3932be9ea4a7a2fd52ccdc51cc6daff4fdabf (patch)
treeec4c35a6fce26e2224b0988545c00c1df61c03e8 /PKGBUILD
downloadaur-surf-randoragon-git.tar.gz
Init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b682db8c4e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Randoragon <randoragongamedev@gmail.com>
+
+pkgname=surf-randoragon-git
+pkgver=1.0.r588.31e49bf
+pkgrel=1
+epoch=
+pkgdesc="Randoragon's build of the suckless surf web browser"
+arch=('x86_64')
+url="https://github.com/randoragon/surf"
+license=('MIT')
+depends=(libx11 webkit2gtk xorg-xprop)
+makedepends=(git)
+optdepends=('dmenu')
+source=("git+$url")
+md5sums=('SKIP')
+provides=('surf')
+conflicts=('surf')
+
+pkgver() {
+ cd surf
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd surf
+ make
+}
+
+package() {
+ cd surf
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -Dm644 README.MD "$pkgdir/usr/share/doc/$pkgname/README.MD"
+}
+