summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaximilian Luz2021-02-05 04:37:10 +0100
committerMaximilian Luz2021-02-05 04:37:10 +0100
commit60fd74b901d5810a0863c4328b53b7eff7961488 (patch)
treed2dd036e7fad363ae4dd38f4d97ee52e782acec4 /PKGBUILD
parent7d5d6aa92c1485067076a211f3fb3746a74457f3 (diff)
downloadaur-60fd74b901d5810a0863c4328b53b7eff7961488.tar.gz
Update to v0.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 509efb8b7664..652bee85a966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='surface-control'
pkgname="${_pkgname}-bin"
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
_pkgrel=1
pkgdesc='Control various aspects of Microsoft Surface devices from the Command-Line'
@@ -18,12 +18,16 @@ source=(
"https://github.com/linux-surface/surface-control/releases/download/v${pkgver}-${_pkgrel}/surface-control-${pkgver}.${_pkgrel}-${CARCH}.bin.tar.xz"
)
-sha256sums=('21cf5399e3e6efad884a10a3fcd449f1e11d0c742aae8e3c019a15d844a3e263')
+sha256sums=('193f5925d47bd485478dd6516b39d7cc2c8e7e865fdf137f3b58491d38a16e84')
package() {
install -D -m755 "bin/surface" "$pkgdir/usr/bin/surface"
+ # copy system files
+ install -D -m644 "usr/lib/sysusers.d/surface-control.conf" "${pkgdir}/usr/lib/sysusers.d/surface-control.conf"
+ install -D -m644 "usr/lib/udev/rules.d/40-surface-control.rules" "${pkgdir}/usr/lib/udev/rules.d/40-surface-control.rules"
+
# completion files
install -D -m644 "shell-completions/surface.bash" "$pkgdir/usr/share/bash-completion/completions/surface"
install -D -m644 "shell-completions/surface.zsh" "$pkgdir/usr/share/zsh/site-functions/_surface"