summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyndair2022-04-12 11:00:57 +0100
committerkyndair2022-04-12 11:00:57 +0100
commit2fa3376fda4f245f03e9148d933cd6907f9802a5 (patch)
treefd64348fb541df031f2f4b01ed83d4f01e29c393 /PKGBUILD
downloadaur-2fa3376fda4f245f03e9148d933cd6907f9802a5.tar.gz
first effort with getting it going
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c54025d1984
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+pkgname=surfshark-wireguard-git
+_pkgname=linux-surfshark-wireguard
+pkgver=v0.2.0.beta.r1.gad05edb
+pkgrel=1
+pkgdesc="Sets-up a vpn interface using wg-quick"
+arch=('any')
+url="https://github.com/kyndair/linux-surfshark-wireguard"
+license=('MIT')
+depends=('wireguard-tools' 'jq' 'curl')
+provides=('surfshark-wireguard')
+install=surfshark-wireguard-git.install
+source=('git+https://github.com/kyndair/linux-surfshark-wireguard.git'
+ 'https://addons.mozilla.org/user-media/addon_icons/963/963216-64.png')
+sha256sums=('SKIP'
+ 'df9dda0009bf36dec4caf5de47f07ad36d12fe7b96ba2faa22448f5e124bc012')
+
+# update the package version to the current git version
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ # install script and config
+ install -Dm770 "${srcdir}/${_pkgname}/gen_wg_config.bash" "${pkgdir}/opt/surfshark-wireguard/gen_wg_config.sh"
+ install -Dm660 "${srcdir}/${_pkgname}/config.json.sample" "${pkgdir}/opt/surfshark-wireguard/config.json"
+ # install icon
+ install -Dm644 "${srcdir}/963216-64.png" "${pkgdir}/usr/share/pixmaps/surfshark-wireguard.png"
+ # install readme
+ install -Dm660 "${srcdir}/${_pkgname}/README.md" "${pkgdir}/usr/share/doc/surfshark-wireguard/README.md"
+ # install link
+ mkdir "${pkgdir}/usr/bin"
+ ln -s /opt/surfshark-wireguard/gen_wg_config.sh "${pkgdir}/usr/bin/surfshark-wireguard"
+}