summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustavo Reis2018-10-27 20:14:50 -0300
committerGustavo Reis2018-10-27 20:14:50 -0300
commit0e4a28c62133351381d216c9171cc03a92ae599b (patch)
treee24b92d50e98c15938daab3fb29bfc8d8e01742f /PKGBUILD
parent5fd56962b3f4567495e87832a3af867035dda627 (diff)
downloadaur-0e4a28c62133351381d216c9171cc03a92ae599b.tar.gz
Small git and upgrade fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a536b58417d..166a921af650 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
_gitname=suru-plus
pkgname=suru-plus-git
-pkgver=20.3.0
-pkgrel=1
+pkgver=20.3.1
+pkgrel=2
pkgdesc="Suru++ 20 — A cyberpunk, elegant, futuristic and modern third-party icons theme!"
arch=('any')
url="https://github.com/gusbemacbe/${_gitname}"
license=('GPL3')
+changelog=CHANGELOG
makedepends=('git')
options=('!strip')
conflicts=(${_gitname})
@@ -18,7 +19,8 @@ sha256sums=('SKIP')
pkgver()
{
cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ # printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package()