summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 16:22:03 -0600
committerBrian Bidulock2015-06-10 16:22:03 -0600
commitb0d59725771e1abbea911ee240eedb0db548664b (patch)
tree4b9423ff0c308841bbcb1e23b6ac5098bb1c22a7 /PKGBUILD
downloadaur-b0d59725771e1abbea911ee240eedb0db548664b.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b3a967376f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Black_Codec
+
+pkgname=suxpanel
+pkgver=0.4b
+pkgrel=3
+pkgdesc="A lightweight X11 desktop panel"
+arch=('x86_64' 'i686')
+url="http://suxpanel.berlios.de/"
+license=('GPL')
+depends=('gtk2' 'libwnck')
+source=(http://download.berlios.de/suxpanel/$pkgname-$pkgver.tar.gz)
+md5sums=('a89d1b4fde46db553d326ca69c392441')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ sed -e 's, -lgobject-2.0, -lgmodule-2.0 -lgobject-2.0,' -i Makefile
+ sed -e 's,/usr/share/suxpanel/plugins,/usr/lib/suxpanel/plugins,' -i Makefile
+ sed -e 's, -shared , -fPIC -shared ,' -i Makefile
+ sed -e 's,/usr/share/suxpanel/plugins,/usr/lib/suxpanel/plugins,' -i suxpanel-install.sh
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib/suxpanel/plugins"
+ make DESTDIR="$pkgdir" install
+ cp ./suxpanel-install.sh $pkgdir/usr/share/suxpanel/
+}