summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuang Luong2021-04-06 20:25:05 +0700
committerQuang Luong2021-04-06 20:25:05 +0700
commitd7046dc7b8432ed3aca64fa361fd43a04a0e3e4e (patch)
treec7ee36bdfe5457f930e91b9851eea521fa7d8b83 /PKGBUILD
parent46e098bd37ac2a8c0d6a236b7806e74d60a8d217 (diff)
downloadaur-d7046dc7b8432ed3aca64fa361fd43a04a0e3e4e.tar.gz
use default python
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b21fcb14bc77..e074fc1e4aab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: max_meyer <dev@fedux.org>
pkgname=svg2tikz-git
-pkgver=r203.d138c81
+pkgver=r216.7a9959c
pkgrel=1
pkgdesc="set of tools for converting SVG graphics to TikZ/PGF code"
arch=('any')
url="https://github.com/kjellmf/svg2tikz"
license=('GPL')
-depends=('python2-lxml')
+depends=('python-lxml')
makedepends=('git')
provides=('inkscape-tikz')
conflicts=('inkscape-tikz')
@@ -26,20 +26,11 @@ pkgver() {
prepare() {
cd "$srcdir"/"$_gitname"
[[ -d build ]] || rm -rf build
- cd $_gitname
- for _i in inkexlib/inkex.py \
- inkexlib/simplepath.py \
- inkexlib/simplestyle.py \
- extensions/tikz_export.py \
- extensions/tikz_export.py
- do
- sed -i '1s+python$+python2+' ${_i}
- done
}
package() {
cd "$srcdir/$_gitname"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1
_inkscape_ext="$pkgdir/usr/share/inkscape/extensions"
install -d "$_inkscape_ext"
cp ./svg2tikz/extensions/tikz_export* "$_inkscape_ext"