summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNils Czernia2017-12-12 10:07:07 +0100
committerNils Czernia2017-12-12 10:07:07 +0100
commit7becc20cc999281cf2ef352feb70c16865e9c163 (patch)
tree0dc0c6ed669250aeffa2ca03edfc302abe61846a /PKGBUILD
downloadaur-7becc20cc999281cf2ef352feb70c16865e9c163.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..882408fee252
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Nils Czernia (DL1CAF) <nils@czserver.de>
+# Based on the package of Carsten Feuls
+# Contributer: Amateurfunk Station der Hochschule Niederrhein (DF0FN) <df0fn@hs-niederrhein.de>
+
+pkgname=('svxlink-git')
+_pkgname=('svxlink')
+pkgver=14.08.2.766.g380e5333
+pkgrel=1
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+url="http://sourceforge.net/projects/svxlink/"
+license=('GPL')
+source=("${_pkgname}::git+https://github.com/sm0svx/svxlink.git"
+ "svxlink.service"
+ "remotetrx.service")
+sha256sums=('SKIP'
+ 'adc29c81df1794b62bd47202af388397c886cc86a95fa05b3446b3a93a1b3a7c'
+ '41adf7f9863f1ea3013b079e628455a22c29d1b369d174bd19905334c9c31543')
+depends=('alsa-utils' 'alsa-lib' 'libsigc++' 'gsm' 'libgcrypt' 'popt' 'tcl' 'speex' 'opus')
+makedepends=('cmake')
+pkgdesc="Echolink Software to provide Ham Radio Voip Operations"
+optdepends=('svxlink-sounds-en_us-heather-8k: provides speech sound files in medium quality'
+ 'svxlink-sounds-en_us-heather-16k: provides speech sound files in high quality')
+backup=('etc/svxlink/svxlink.conf'
+ 'etc/svxlink/TclVoiceMail.conf'
+ 'etc/svxlink/remotetrx.conf'
+ 'etc/svxlink/svxlink.d/ModuleDtmfRepeater.conf'
+ 'etc/svxlink/svxlink.d/ModuleEchoLink.conf'
+ 'etc/svxlink/svxlink.d/ModuleHelp.conf'
+ 'etc/svxlink/svxlink.d/ModuleMetarInfo.conf'
+ 'etc/svxlink/svxlink.d/ModuleParrot.conf'
+ 'etc/svxlink/svxlink.d/ModulePropagationMonitor.conf'
+ 'etc/svxlink/svxlink.d/ModuleSelCallEnc.conf'
+ 'etc/svxlink/svxlink.d/ModuleTclVoiceMail.conf')
+install=svxlink.install
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+build(){
+ cd "${srcdir}/${_pkgname}/src"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DLOCAL_STATE_DIR=/var -DUSE_QT=NO ..
+ make
+ make doc
+}
+
+package(){
+ make -C ${srcdir}/${_pkgname}/src/build DESTDIR="${pkgdir}" install
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ mkdir -p "${pkgdir}/var/spool/svxlink"
+ # svxlink systemd service file
+ cp ${srcdir}/svxlink.service ${pkgdir}/usr/lib/systemd/system
+ cp ${srcdir}/remotetrx.service ${pkgdir}/usr/lib/systemd/system
+}