summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreyXor2023-08-29 09:29:30 +0200
committerGreyXor2023-08-29 09:29:30 +0200
commit52983f65d46caf39ae375dd5f9455c0883d9b3d9 (patch)
tree3eb46701ce3a7409ea40a5ea69fd1399d1649397 /PKGBUILD
parent0a7343fba3917ec8c6ce959cac73872e8f05152c (diff)
downloadaur-52983f65d46caf39ae375dd5f9455c0883d9b3d9.tar.gz
revert commit version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 38 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f8c0a0de0f2..a795e7cdacb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,62 +10,62 @@ pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager'
url='https://swaywm.org'
license=('MIT')
depends=(
- "cairo"
- "gdk-pixbuf2"
- "glib2"
- "glibc"
- "json-c"
- "libevdev"
- "libinput"
- "libxcb"
- "libxkbcommon"
- "pango"
- "pcre2"
- "pixman"
- "systemd-libs"
- "wayland"
- "wlroots-git"
- "xcb-util-wm"
+ "cairo"
+ "gdk-pixbuf2"
+ "glib2"
+ "glibc"
+ "json-c"
+ "libevdev"
+ "libinput"
+ "libxcb"
+ "libxkbcommon"
+ "pango"
+ "pcre2"
+ "pixman"
+ "systemd-libs"
+ "wayland"
+ "wlroots-git"
+ "xcb-util-wm"
)
makedepends=(
- "git"
- "libcap"
- "meson"
- "scdoc"
- "wayland-protocols"
+ "git"
+ "libcap"
+ "meson"
+ "scdoc"
+ "wayland-protocols"
)
optdepends=(
- 'dmenu: Application launcher used in default configuration'
- 'foot: Terminal emulator used in default configuration'
- 'polkit: System privilege control. Required if not using seatd service'
- 'swaybg-git: Wallpaper tool for sway'
- 'swayidle-git: Idle management daemon'
- 'swaylock-git: Screen locker'
- 'xorg-xwayland: X11 support'
+ 'dmenu: Application launcher used in default configuration'
+ 'foot: Terminal emulator used in default configuration'
+ 'polkit: System privilege control. Required if not using seatd service'
+ 'swaybg-git: Wallpaper tool for sway'
+ 'swayidle-git: Idle management daemon'
+ 'swaylock-git: Screen locker'
+ 'xorg-xwayland: X11 support'
)
install=sway-git.install
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=("etc/sway/config")
-source=("${pkgname}::git+https://github.com/swaywm/sway.git#commit=4a22105"
- "50-systemd-user.conf")
+source=("${pkgname}::git+https://github.com/swaywm/sway.git"
+"50-systemd-user.conf")
b2sums=('SKIP'
- '95e0862807c3b5bb490b88c46e6d2d4deaa8ba0d18be0c169f3d57606acbfa124cb712b48b22ab6f12f247ac5b8d5d3cf4db85f7b04420845c0e3ed742edf917')
+ '95e0862807c3b5bb490b88c46e6d2d4deaa8ba0d18be0c169f3d57606acbfa124cb712b48b22ab6f12f247ac5b8d5d3cf4db85f7b04420845c0e3ed742edf917')
pkgver() {
- # Calculate the version dynamically using git information
- printf "r%s.%s" "$(git -C "$srcdir/${pkgname}" rev-list --count HEAD)" "$(git -C "$srcdir/${pkgname}" rev-parse --short HEAD)"
+ # Calculate the version dynamically using git information
+ printf "r%s.%s" "$(git -C "$srcdir/${pkgname}" rev-list --count HEAD)" "$(git -C "$srcdir/${pkgname}" rev-parse --short HEAD)"
}
build() {
- arch-meson "${pkgname}" build -D sd-bus-provider=libsystemd -D werror=false
+ arch-meson "${pkgname}" build -D sd-bus-provider=libsystemd -D werror=false
- meson compile -C build
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "$pkgdir"
- install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
- install -Dm644 "${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+ install -Dm644 "${pkgname}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}