summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreyXor2023-08-25 16:22:15 +0200
committerGreyXor2023-08-25 16:22:15 +0200
commit902ef18128c880cd140cd8d63bbf889962a66a66 (patch)
tree50635c8419a7e8527860af6d9a671ff799b521b1 /PKGBUILD
parenta1414cb4e2cbea87f5208de350cff412f28c2d66 (diff)
downloadaur-902ef18128c880cd140cd8d63bbf889962a66a66.tar.gz
use the sway-contrib repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9c83cbb2fb6..5c518154acdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=sway-git
_pkgname=sway
-pkgver=r6984.e40eb338
+pkgver=r7177.4a221057
pkgrel=1
license=("MIT")
pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager"
@@ -40,8 +40,10 @@ backup=(etc/sway/config)
arch=("i686" "x86_64")
url="https://swaywm.org"
source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git"
+ "sway-contrib::git+https://github.com/OctopusET/sway-contrib.git"
50-systemd-user.conf)
sha512sums=('SKIP'
+ 'SKIP'
'c2b7d808f4231f318e03789015624fd4cf32b81434b15406570b4e144c0defc54e216d881447e6fd9fc18d7da608cccb61c32e0e1fab2f1fe2750acf812d3137')
provides=("sway")
conflicts=("sway")
@@ -68,8 +70,9 @@ package() {
cd "$_pkgname"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "../sway-contrib"
for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
- install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
+ install -Dm755 "$util" -t "$pkgdir/usr/share/$pkgname/scripts"
done
}