summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonin Décimo2020-10-23 22:52:17 +0200
committerAntonin Décimo2020-10-23 22:52:17 +0200
commit6c74001bca121b131e8aeee0801737142a49788c (patch)
tree18ccbbea4a6f381a7e66d474cb4c7f7ac4aca6d8 /PKGBUILD
parentdb2cdc8d6b358fa3d0e0f75383b42523180231d3 (diff)
parent5508e76470074eaaf6309f14236d00c03c7f93fe (diff)
downloadaur-6c74001bca121b131e8aeee0801737142a49788c.tar.gz
Merge branch 'sway-master' into hidpi-master
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 45 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e98c90992e91..f895d1bef033 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,63 @@
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=sway-hidpi-git
_pkgname=sway-hidpi
-pkgver=r6437.ea3ba203
+pkgver=r6506.1be66c98
pkgrel=1
license=("MIT")
-pkgdesc="i3-compatible Wayland compositor, with XWayland HiDPI"
-makedepends=("meson" "git" "scdoc" "wayland-protocols" "ninja")
+pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager, with XWayland HiDPI"
+makedepends=(
+ "git"
+ "meson"
+ "ninja"
+ "scdoc"
+ "wayland-protocols"
+)
depends=(
- "json-c" "pcre" "wlroots-hidpi-git" "cairo" "pango" "gdk-pixbuf2" "pam"
- "xorg-server-xwayland-hidpi-git" "swaybg-git" "xsettingsd"
+ "cairo"
+ "gdk-pixbuf2"
+ "json-c"
+ "pango"
+ "polkit"
+ "pcre"
+ "swaybg-git"
+ "ttf-font"
+ "wlroots-hidpi-git"
+ "xorg-server-xwayland-hidpi-git"
+ "xsettingsd"
)
optdepends=(
- "alacritty: Default terminal emulator."
- "dmenu: Default for launching applications."
- "i3status: To display system information with a bar."
- "swayidle-git: Idle management daemon for Sway."
- "swaylock-git: Screen locker for Sway."
+ "alacritty: Terminal emulator used by the default config"
+ "dmenu: Application launcher"
+ "grim: Screenshot utility"
+ "i3status: Status line"
+ "mako: Lightweight notification daemon"
+ "slurp: Select a region"
+ "swayidle: Idle management daemon"
+ "swaylock: Screen locker"
+ "wallutils: Timed wallpapers"
+ "waybar: Highly customizable bar"
)
+backup=(etc/sway/config)
arch=("i686" "x86_64")
url="https://swaywm.org"
source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git"
+ "50-systemd-user.conf"
"xwayland_hidpi.diff::https://github.com/swaywm/sway/pull/5090.diff")
sha512sums=('SKIP'
+ '57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e'
'813863fe8d391761770eb264b1c0a2d9442efde3e79fae6b78386ed7c041906eef60bbf9d9bc7d118494de8aba2cd4c45a13dcd2ca09f3f1cd1157e74f122667')
provides=("sway")
conflicts=("sway")
options=(debug !strip)
-pkgver() {
+prepare() {
cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ patch -Np1 -i ../xwayland_hidpi.diff
}
-prepare() {
+pkgver() {
cd "$_pkgname"
- patch -Np1 -i ../xwayland_hidpi.diff
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -48,6 +71,14 @@ build() {
}
package() {
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+
cd "$_pkgname"
DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
+ install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
+ done
}