summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonin Décimo2021-02-16 01:14:36 +0100
committerAntonin Décimo2021-02-16 01:18:45 +0100
commitbac6b2fca88cfea53f182d3128ca39d299de5358 (patch)
treec32117552ce7be22139e59f79413ad72b2eb5ea5 /PKGBUILD
parent30438c35deb47d0231c6f45d7abbbd7d2eaffdae (diff)
downloadaur-bac6b2fca88cfea53f182d3128ca39d299de5358.tar.gz
Update meson build script and follow packaging recommendations
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3902fadbd2e..26e0fc5749ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Contributor: Drew DeVault <sir@cmpwn.com>
pkgname=sway-hidpi-git
_pkgname=sway-hidpi
-pkgver=r6575.97adba05
+pkgver=r6605.42cbaf27
pkgrel=1
license=("MIT")
pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager, with XWayland HiDPI (git version)"
makedepends=(
"git"
"meson"
- "ninja"
"scdoc"
"wayland-protocols"
)
@@ -62,22 +61,21 @@ pkgver() {
}
build() {
- cd "$_pkgname"
- meson \
+ arch-meson \
+ --buildtype debugoptimized \
+ -Dsd-bus-provider=libsystemd \
-Dwerror=false \
- --prefix /usr \
- "$srcdir/build"
- ninja -C "$srcdir/build"
+ "$_pkgname" build
+ meson compile -C build
}
package() {
install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
- cd "$_pkgname"
- DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+ DESTDIR="$pkgdir" meson install -C build
+ cd "$_pkgname"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
done