summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonin Décimo2020-05-02 18:53:00 +0200
committerAntonin Décimo2020-05-02 18:55:05 +0200
commitbefe812438c7cfecea335ed6511158f5e90ae78c (patch)
tree33c1f98dc5661ee7006c14a09ee3f8d4df15958a /PKGBUILD
parentc7e90443178d23c6a7c779ec95897649b1452ef4 (diff)
downloadaur-befe812438c7cfecea335ed6511158f5e90ae78c.tar.gz
Add HiDPI support.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e655a7a86779..9b9411702d69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
-pkgname=sway-git
-_pkgname=sway
-pkgver=r5942.3f77591b
+# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
+pkgname=sway-hidpi-git
+_pkgname=sway-hidpi
+pkgver=r6341.ae3ec745
pkgrel=1
license=("MIT")
-pkgdesc="i3-compatible Wayland compositor"
+pkgdesc="i3-compatible Wayland compositor, with XWayland HiDPI"
makedepends=("meson" "git" "scdoc" "wayland-protocols" "ninja")
depends=(
- "json-c" "pcre" "wlroots-git" "cairo" "pango" "gdk-pixbuf2" "pam"
- "xorg-server-xwayland" "swaybg-git"
+ "json-c" "pcre" "wlroots-hidpi-git" "cairo" "pango" "gdk-pixbuf2" "pam"
+ "xorg-server-xwayland-hidpi-git" "swaybg-git" "xsettingsd"
)
optdepends=(
"alacritty: Default terminal emulator."
@@ -19,8 +20,10 @@ optdepends=(
)
arch=("i686" "x86_64")
url="https://swaywm.org"
-source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git")
-sha512sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git"
+ "https://github.com/swaywm/sway/pull/5090.diff")
+sha512sums=('SKIP'
+ 'SKIP')
provides=("sway")
conflicts=("sway")
options=(debug !strip)
@@ -32,6 +35,7 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ patch -Np1 -i ../5090.diff
}
build() {