summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Stoeckl2023-01-28 11:45:08 -0500
committerManuel Stoeckl2023-01-28 11:45:08 -0500
commitc0c4d0ca9b7ef0283bad8c9af2e30ec637cdc4db (patch)
tree36d7adcff433a364c9149b26c42a549975d50ab7 /PKGBUILD
parent6811283642b96299081472c662bccc9b480843a2 (diff)
downloadaur-c0c4d0ca9b7ef0283bad8c9af2e30ec637cdc4db.tar.gz
Simplify build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef132f61e842..d6a658727047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Stephen Gregoratto <dev@sgregoratto.me>
# Contributor: gilbus <aur@tinkershell.eu>
pkgname=swaylock-plugin-git
-pkgver=1.5.r61.g44d6234
+pkgver=r313.9f49b8d
pkgrel=1
pkgdesc='Screen locker for Wayland -- Fork with background plugin support '
url='https://github.com/mstoeckl/swaylock-plugin'
@@ -24,16 +24,9 @@ pkgver() {
)
}
-prepare() {
- cd "${pkgname%-git}"
- # Fix ticket FS#31544, sed line taken from gentoo
- sed -i -e 's:login:system-auth:' "pam/swaylock"
-}
-
build() {
mkdir -p build
- # makepkg is unable to strip the binary, so we tell meson to do it.
- arch-meson build "${pkgname%-git}" -Dwerror=false --strip
+ arch-meson build "${pkgname%-git}" -Dwerror=false
ninja -C build
}