summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWitalij Berdinskich2021-03-20 00:07:47 +0200
committerWitalij Berdinskich2021-03-20 00:07:47 +0200
commite0d057f32e738efd82f16079224a1e6a50abe056 (patch)
tree22eea132a1f979e07f479b8d87c09680eea740b8 /PKGBUILD
parent7510d17702647df3dbb0750a72a99158007a0378 (diff)
downloadaur-e0d057f32e738efd82f16079224a1e6a50abe056.tar.gz
Add three command to upload a screenshot to x0.at; Change license to GPL3.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5c51e4e63d7..b2dd22911e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Vitaliy Berdinskikh <ur6lad at gmail dot com>
pkgname=swayshot
-pkgver=2.2.0
-pkgrel=2
+pkgver=2.3.0
+pkgrel=1
pkgdesc='Sway screenshots: screen, window or region.'
arch=('any')
url='https://gitlab.com/radio_rogal/swayshot'
-license=('Apache')
+license=('GPL3')
depends=('sway' 'xdg-user-dirs' 'grim' 'slurp' 'jq')
optdepends=('wl-clipboard: copy the full path to clipboard'
'xsel: copy the full path to clipboard'
- 'xclip: copy the full path to clipboard')
+ 'xclip: copy the full path to clipboard'
+ 'curl: upload a screenshot to x0.at')
conflicts=('swaygrab-helper')
source=(https://gitlab.com/radio_rogal/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('4cb7f6317f79b7396940464c8a5974bdc5fe01f546f0a6920ea4d7060f848e01')
+sha256sums=('ece411f2fe889dc6baf1288801f5659f277f7b296fc06a269323b22649d94bc6')
package() {
cd "$srcdir"/$pkgname-$pkgver
install -d "$pkgdir"/etc/sway/config.d
- install -m 644 $pkgname.config "$pkgdir"/etc/sway/config.d/$pkgname
+ install -m 644 $pkgname.conf "$pkgdir"/etc/sway/config.d
install -d "$pkgdir"/usr/bin
install -m 755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
}