summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShinyzenith2022-04-07 15:12:42 +0530
committerShinyzenith2022-04-07 15:12:42 +0530
commit1e64531030e0ce11570ce24948684b7b00918908 (patch)
tree458350ba5416532d41aa2254da5799aba4398965 /PKGBUILD
parent3f35ee572892d5cb90e9c1a5faccef3b347a40c4 (diff)
downloadaur-1e64531030e0ce11570ce24948684b7b00918908.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a12a66d6595..1082170a4ef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
# Maintainer: Aakash Sharma <aakashsensharma@gmail.com>
+# Contributor: Sergey A. <murlakatamenka@disroot.org>
+
pkgname='swhkd-git'
_pkgname="swhkd"
pkgver=1.1.7.480.ge4a1a89
@@ -23,12 +25,10 @@ package() {
cd "$_pkgname"
install -Dm 755 ./bin/swhkd "$pkgdir/usr/bin/swhkd"
install -Dm 755 ./bin/swhks "$pkgdir/usr/bin/swhks"
- install -Dm 644 ./com.github.swhkd.pkexec.policy "$pkgdir/usr/share/polkit-1/actions/com.github.swhkd.pkexec.policy"
- install -dm700 "$pkgdir/etc/swhkd/runtime"
- chown root:root "$pkgdir/etc/swhkd/runtime"
- chmod 700 "$pkgdir/etc/swhkd/runtime"
- chmod 644 "$pkgdir/usr/share/polkit-1/actions/com.github.swhkd.pkexec.policy"
- chown root:root "$pkgdir/etc/swhkd/runtime"
+
+ install -Dm 644 -o root ./com.github.swhkd.pkexec.policy -t "$pkgdir/usr/share/polkit-1/actions"
+
+ install -dm 700 -o root "$pkgdir/etc/swhkd/runtime"
}
pkgver() {