summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsoloturn2020-09-30 21:10:51 +0200
committersoloturn2020-09-30 21:10:51 +0200
commit4edcae9dc92b7076c1ec72f48c48bf712e80b69f (patch)
treed5ed9d7d176929a0dd1056ca83f4ad2a685e538c /PKGBUILD
parent3fec64add0e089b5d08c45446a80897191d29728 (diff)
downloadaur-4edcae9dc92b7076c1ec72f48c48bf712e80b69f.tar.gz
unset CPPFLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 210542bc0e06..f71ca6624014 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -87,7 +87,12 @@ build() {
find "$srcdir/swift/stdlib/public/SwiftShims" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
find "$srcdir/llvm-project/clang" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
find "$srcdir/llvm-project/clang-tools-extra" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
- LDFLAGS='-ldl -lpthread' python swift/utils/build-script --preset=buildbot_linux,no_test install_destdir="$srcdir/build" installable_package="$srcdir/swift-arch-pkg.tar.gz"
+# _build_script_wrapper -R "${_common_build_params[@]}"
+
+ # by default in /etc/makepkg.conf this is "-D_FORTIFY_SOURCE=2"
+ # which will break `compiler-rt`, so unset
+ unset CPPFLAGS
+ python swift/utils/build-script --preset=buildbot_linux,no_test install_destdir="$srcdir/build" installable_package="$srcdir/swift-arch-pkg.tar.gz"
}
check() {