summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsoloturn2020-09-13 22:05:27 +0200
committersoloturn2020-09-13 22:05:27 +0200
commit59e25e1c183af206ba42eb600050f3a63faa0b52 (patch)
treef1a42bd8a3544caa4ccaae67fe3c312dd24da794 /PKGBUILD
parentf4ec29da3864ae4525effa26a2b86ce7d95d0003 (diff)
downloadaur-59e25e1c183af206ba42eb600050f3a63faa0b52.tar.gz
do not set -ldl -lpthread LDFAGS, other small cleanups
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c11a44838975..5f975188226f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -78,15 +78,12 @@ build() {
find "$srcdir/swift/stdlib/public/SwiftShims" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
find "$srcdir/llvm-project/clang" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
find "$srcdir/llvm-project/clang-tools-extra" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
- # Release build
- #LDFLAGS='-ldl -lpthread' python utils/build-script -b -p --foundation --xctest -R
# By default in /etc/makepkg.conf this is "-D_FORTIFY_SOURCE=2"
# Which will break `compiler-rt`
unset CPPFLAGS
- LDFLAGS='-ldl -lpthread' python swift/utils/build-script --preset=buildbot_linux,no_test install_destdir="/opt/swift" installable_package="$srcdir/swift.tar.gz" || true
- find . -name clang++
+ python swift/utils/build-script --preset=buildbot_linux,no_test install_destdir="/opt/swift" installable_package="$srcdir/swift.tar.gz"
}
package() {