summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkdols2023-12-31 17:15:37 -0600
committerMarkdols2023-12-31 17:15:37 -0600
commit2c9feae34a345b09955c2a1d39e015beaf3d55a2 (patch)
treef53a6125b8b7c42539096257e309a39dbe281456 /PKGBUILD
parent72c43b0b76b596db39b1ec245e97d565ab91c2ee (diff)
downloadaur-2c9feae34a345b09955c2a1d39e015beaf3d55a2.tar.gz
switched from centos7 source to ubi9 source, changed optional python dependency to python39, removed dependency on ncurses5-compat-libs in favor of just ncurses
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6312e3c63ae..f173c519ee7c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname=swiftly
pkgname=swiftly-bin
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Swift toolchain installer and manager, written in Swift."
arch=('x86_64')
url="https://swift-server.github.io/swiftly/"
license=('apache')
-depends=('libutil-linux' 'libxml2' 'ncurses5-compat-libs')
-optdepends=('python36: required for REPL')
+depends=('libutil-linux' 'libxml2' 'ncurses')
+optdepends=('python39: required for REPL')
options=('!strip')
provides=(swift-language)
conflicts=(swift-language)
@@ -20,9 +20,17 @@ install='swiftly-bin.install'
package() {
mkdir -p ~/.local/share/${_pkgname}/toolchains
if [ ! -f ~/.local/share/${_pkgname}/config.json ]; then
- echo "{ \"platform\": { \"name\": \"centos7\", \"nameFull\": \"centos7\", \"namePretty\": \"Arch Linux\" }, \"installedToolchains\": [] }" > ~/.local/share/${_pkgname}/config.json # basic config.json setup
+ echo "{ \"platform\": { \"name\": \"ubi9\", \"nameFull\": \"ubi9\", \"namePretty\": \"Arch Linux\" }, \"installedToolchains\": [] }" > ~/.local/share/${_pkgname}/config.json # basic config.json setup
fi
+
install -D -m 0755 ${_pkgname}-x86_64-unknown-linux-gnu ${pkgdir}/usr/bin/${_pkgname}
+
+ # setting up symlinks to existing ncurses libs (no ncurses5-compat-libs needed!)
+ mkdir -p ${pkgdir}/usr/lib
+ ln -s /usr/lib/libncursesw.so.6 ${pkgdir}/usr/lib/libncurses.so.6
+ ln -s /usr/lib/libformw.so.6 ${pkgdir}/usr/lib/libform.so.6
+ ln -s /usr/lib/libpanelw.so.6 ${pkgdir}/usr/lib/libpanel.so.6
+
echo "Config and toolchains can be found in ~/.local/share/${_pkgname}. Toolchains are installed to ~/.local/bin."
echo "If you encounter an error stating that config.json cannot be found, please do a clean build of this package."
}