summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Maingot2022-01-19 19:16:29 -0800
committerJulian Maingot2022-01-19 22:13:11 -0800
commit44006dde17f9a7537d296a5a397514fe1b4033ca (patch)
tree7e058cf5eb5bbdde78c5c48275f69e479e889fe0 /PKGBUILD
parent42515dadcb8042daad811239aeb1844c61b6f7dc (diff)
downloadaur-44006dde17f9a7537d296a5a397514fe1b4033ca.tar.gz
add submodules as sources, update build variables
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a9af50507b7..032daa00ff7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=swiftshader-git
pkgver=r6374.2e74d5dc03
-pkgrel=1
+pkgrel=2
pkgdesc='High-performance CPU-based implementation of the Vulkan graphics API12.'
arch=(x86_64)
url=https://swiftshader.googlesource.com/SwiftShader
@@ -10,9 +10,15 @@ provides=(swiftshader libgl opengl-driver vulkan-driver)
conflicts=(swiftshader)
license=(Apache)
source=("git+$url#branch=master"
- git+https://github.com/google/googletest.git
- git+https://github.com/ianlancetaylor/libbacktrace.git)
-sha1sums=('SKIP' 'SKIP' 'SKIP')
+ git+https://github.com/google/cppdap
+ git+https://github.com/google/googletest.git
+ git+https://github.com/nlohmann/json.git
+ git+https://github.com/ianlancetaylor/libbacktrace.git
+ git+https://github.com/powervr-graphics/Native_SDK.git
+ git+https://github.com/google/benchmark.git
+ git+https://github.com/KhronosGroup/glslang.git
+)
+sha1sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
depends=()
makedepends=(git cmake ninja)
@@ -25,18 +31,22 @@ pkgver() {
prepare() {
git -C SwiftShader submodule init
- # this repo is not publicly accessible so we won't fetch it
- git -C SwiftShader config submodule."third_party/git-hooks".update none
+ git -C SwiftShader config submodule."third_party/cppdap".url "$srcdir/cppdap"
git -C SwiftShader config submodule."third_party/googletest".url "$srcdir/googletest"
+ git -C SwiftShader config submodule."third_party/json".url "$srcdir/json"
git -C SwiftShader config submodule."third_party/libbacktrace/src".url "$srcdir/libbacktrace"
- git -C SwiftShader submodule update --depth=1
+ git -C SwiftShader config submodule."third_party/PowerVR_Examples".url "$srcdir/Native_SDK"
+ git -C SwiftShader config submodule."third_party/benchmark".url "$srcdir/benchmark"
+ git -C SwiftShader config submodule."third_party/glslang".url "$srcdir/glslang"
+ # this repo is not publicly accessible so we won't fetch it
+ git -C SwiftShader config submodule."third_party/git-hooks".update none
+ git -C SwiftShader submodule update
cmake \
-G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -D WARNINGS_AS_ERRORS=off \
- -D BUILD_SAMPLES=off \
+ -D SWIFTSHADER_WARNINGS_AS_ERRORS=off \
-S SwiftShader -B build
}