summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD3SOX2024-03-13 01:52:37 +0100
committerD3SOX2024-03-13 01:52:37 +0100
commitb9cc954401060c3a116f184084f862e706cb1e47 (patch)
treed032d47d7d74a7a1afda3ed59a5104481cf7049d /PKGBUILD
downloadaur-b9cc954401060c3a116f184084f862e706cb1e47.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e19b17cd5423
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: D3SOX <d3sox at protonmail dot com>
+
+_reponame=Swig
+pkgname=swig-cli
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="An easy to use git config manager"
+arch=(any)
+url="https://github.com/AlexanderDotH/$_reponame"
+license=(custom)
+depends=(git xdg-utils)
+makedepends=(dotnet-host dotnet-sdk)
+options=(!strip)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$_reponame-$pkgver/Build"
+ # modify build.sh to remove dotnet publish lines which do not contain linux
+ sed -i '/linux/! s/^dotnet publish/#dotnet publish/' build.sh
+ chmod +x build.sh
+}
+
+build() {
+ cd "$srcdir/$_reponame-$pkgver/Build"
+ ./build.sh || true
+}
+
+package() {
+ install -Dm644 "$srcdir/$_reponame-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$srcdir/$_reponame-$pkgver/Build/Swig/Linux/Swig.Console" "$pkgdir/usr/bin/swig-cli"
+}