summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrnmst/Franco Masotti2016-10-24 14:13:22 +0200
committerfrnmst/Franco Masotti2016-10-24 14:13:22 +0200
commit66a33ab3bc830ca6f894896710e4f9aa87f43c96 (patch)
treec25c34be76cb351670360b6882f2c29eade14e91 /PKGBUILD
parent00dbb734c3b3b55a81153eb41da66314662b2ecf (diff)
downloadaur-66a33ab3bc830ca6f894896710e4f9aa87f43c96.tar.gz
Updated to the new version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 12 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b6ce979c93e..372882bc4873 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=swish-cplint
pkgver=r1673.4e5dd96
-pkgrel=1
+pkgrel=2
pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite"
arch=('x86_64')
url="https://github.com/friguzzi/swish"
@@ -13,24 +13,18 @@ makedepends=('git'
'bower'
'sed')
conflicts=('swish')
-install=.INSTALL
-source=('git://github.com/friguzzi/swish#branch=master')
+install=.install
+source=('git+https://github.com/friguzzi/swish#branch=master')
md5sums=('SKIP')
-prepare() {
- # Edit the .INSTALL script.
- sed \
- -e "s@startdir=.*@startdir="${startdir}"@" \
- -i ${startdir}/.INSTALL
-}
-
build() {
cd ${srcdir}/swish
bower --allow-root install
make src
# Patch
- cp ${startdir}/run.pl .
- cp ${startdir}/run.sh .
+ cp ../../run.pl .
+ cp ../../run.sh .
+ cp ../../install_web_iface_deps.pl .
}
pkgver () {
@@ -43,11 +37,10 @@ pkgver () {
package() {
cd ${srcdir}
- install -d ${pkgdir}/usr/share/${pkgname}
- install -d ${pkgdir}/usr/bin
- cp -r swish/* ${pkgdir}/usr/share/${pkgname}
- install -D -m644 swish/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 ${startdir}/${pkgname}.service "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
- install -D -m644 ${startdir}/${pkgname}.conf "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
- ln -s /usr/share/${pkgname}/run.sh ${pkgdir}/usr/bin/${pkgname}
+ install -d "${pkgdir}"/usr/share/"${pkgname}"
+ install -d "${pkgdir}"/usr/bin
+ cp -r swish/* "${pkgdir}"/usr/share/"${pkgname}"
+ install -D -m644 swish/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ install -D -m644 ../"${pkgname}".service ${pkgdir}/usr/lib/systemd/system/"${pkgname}".service
+ ln -s /usr/share/"${pkgname}"/run.sh "${pkgdir}"/usr/bin/"${pkgname}"
}