summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 23:02:20 +0200
committerMaxime Gauduin2017-05-01 23:02:20 +0200
commit64629cbdfa1ba5e56e646165b8fe88c94d6a7d48 (patch)
tree7868c889342380650b25ca5e52e5492a009ba393 /PKGBUILD
downloadaur-64629cbdfa1ba5e56e646165b8fe88c94d6a7d48.tar.gz
Add switchboard-plug-desktop-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad27f32b963
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-desktop-git
+pkgver=r741.c6dfa43
+pkgrel=1
+pkgdesc='Switchboard Desktop Plug'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/switchboard-plug-pantheon-shell'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gnome-desktop' 'gtk3' 'libgee' 'plank'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+provides=('switchboard-plug-desktop')
+conflicts=('switchboard-plug-desktop')
+replaces=('switchboard-plug-desktop-bzr')
+source=('switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git'
+ 'switchboard-plug-desktop-paths.patch')
+sha256sums=('SKIP'
+ '75353594da255ecc16b277e65f7a2bdc1a0aef17e6ab30a0be7b8636d60379c5')
+
+pkgver() {
+ cd switchboard-plug-desktop
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd switchboard-plug-desktop
+
+ patch -Np1 -i ../switchboard-plug-desktop-paths.patch
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-desktop/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-desktop/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: