summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2019-03-04 11:48:56 +0100
committerMaxime Gauduin2019-03-04 11:48:56 +0100
commit781e0316b241e972bda141fe4f6e4b927ad87d67 (patch)
treeafec66ff60b9418eb4a0ab9e7afc096689130f2d /PKGBUILD
parent4de8993c48d439ecaaa9fd1d5347ab314e1b75ce (diff)
downloadaur-781e0316b241e972bda141fe4f6e4b927ad87d67.tar.gz
update desktop plug
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 33 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f954fc79f09..f7d29530b657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,37 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-desktop-git
-pkgver=r870.5b0826a
+pkgver=r1039.473a199
pkgrel=1
pkgdesc='Switchboard Desktop Plug'
-arch=('x86_64')
-url='https://github.com/elementary/switchboard-plug-pantheon-shell'
-license=('GPL3')
-groups=('pantheon-unstable')
-depends=('gdk-pixbuf2' 'glib2' 'glibc' 'gnome-desktop' 'gtk3' 'libgee'
- 'libgexiv2' 'plank'
- 'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('git' 'granite-git' 'libgexiv2' 'meson' 'switchboard-git' 'vala')
-provides=('switchboard-plug-desktop')
-conflicts=('switchboard-plug-desktop')
-source=('switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git'
- 'switchboard-plug-desktop-paths.patch')
-sha256sums=('SKIP'
- '75353594da255ecc16b277e65f7a2bdc1a0aef17e6ab30a0be7b8636d60379c5')
+arch=(x86_64)
+url=https://github.com/elementary/switchboard-plug-pantheon-shell
+license=(GPL3)
+groups=(pantheon-unstable)
+depends=(
+ gdk-pixbuf2
+ glib2
+ gnome-desktop
+ gtk3
+ libgee
+ libgexiv2
+ libgranite.so
+ libswitchboard-2.0.so
+ plank
+ tumbler
+)
+makedepends=(
+ git
+ granite-git
+ libgexiv2
+ meson
+ switchboard-git
+ vala
+)
+provides=(switchboard-plug-desktop)
+conflicts=(switchboard-plug-desktop)
+source=(switchboard-plug-desktop::git+https://github.com/elementary/switchboard-plug-pantheon-shell.git)
+sha256sums=(SKIP)
pkgver() {
cd switchboard-plug-desktop
@@ -26,27 +40,16 @@ pkgver() {
}
prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-
- cd switchboard-plug-desktop
-
- patch -Np1 -i ../switchboard-plug-desktop-paths.patch
+ sed 's|/usr/share/backgrounds|/usr/share/backgrounds/elementary|' -i switchboard-plug-desktop/src/Views/Wallpaper.vala
}
build() {
- cd build
-
- arch-meson ../switchboard-plug-desktop
- ninja
+ arch-meson switchboard-plug-desktop build
+ ninja -C build
}
package() {
- cd build
-
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: