summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Boughton2021-07-12 00:20:57 +0100
committerNick Boughton2021-07-12 00:20:57 +0100
commit523da85aae4b289640b3bb287c6cde899269a3da (patch)
tree31755a00faa855d14a6d4bd488699355630fb8ba /PKGBUILD
parent7a891c4dc738eff6bd211012dcea3bc14bd4955b (diff)
downloadaur-523da85aae4b289640b3bb287c6cde899269a3da.tar.gz
new upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95e7b50b08db..5c61bcaadcee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,36 @@
# Maintainer: N.Boughton, <nicholasboughton@gmail.com>
pkgname=swnt
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=1
pkgdesc="Command line GM tools for Stars Without Number"
arch=('x86_64')
url="https://github.com/nboughton/swnt"
license=("MIT")
optdepends=('hugo: export sectors as hugo sites')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nboughton/swnt/releases/download/v${pkgver}/${pkgname}.tar.gz")
-sha1sums=('d4c7564783bce5725f42f40f8ca8191e6a113610')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nboughton/swnt/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('c6f28f6822b699994aed9ac1309aa5c95ae3ca8e5cc6b87ce0fa06e0e390fce6')
-#build() {
-# cd "$srcdir/$pkgname-$pkgver"
-# go build -v -o swnt
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -v -o build
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# go test ./...
#}
package() {
- cd "$srcdir/build/"
- install -Dm755 "${pkgname}.linux" "${pkgdir}/usr/bin/${pkgname}"
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
}