summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYusuf Aktepe2019-11-05 02:29:05 +0300
committerYusuf Aktepe2019-11-05 02:29:33 +0300
commita7ed60fc9c5d374dbe099b274aaae12307e38a87 (patch)
tree59c7a883b32efb0a184dde4dc17656787b821abb /PKGBUILD
downloadaur-a7ed60fc9c5d374dbe099b274aaae12307e38a87.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b1033a26221
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Yusuf Aktepe <yusuf@yusufaktepe.com>
+# Contributor: Doron Behar <doron.behar@gmail.com>
+# Contributor: Jason Ryan <jasonwryan@gmail.com>
+
+_name=sxiv
+pkgname="${_name}-dir-navigation-git"
+pkgver=v25.r10.g07300da
+pkgrel=1
+pkgdesc="Simple X Image Viewer (with patch to browse through images in working directory)"
+arch=('x86_64')
+url="https://github.com/muennich/${_name}"
+license=('GPL2')
+depends=('imlib2' 'desktop-file-utils' 'xdg-utils' 'hicolor-icon-theme' 'libexif' 'libxft')
+makedepends=('git')
+provides=("${_name}")
+conflicts=("${_name}")
+source=("${_name}::git+${url}.git"
+ "dir-navigation.diff")
+sha256sums=('SKIP'
+ 'd2cd688f326c8457f7102d374e6bad96c9922d20e918c3f7020a6ec0d554fef5')
+
+pkgver() {
+ cd "${_name}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_name}"
+ ln -s config.def.h config.h
+
+ echo "==> Applying dir-navigation patch"
+ git apply "$srcdir"/dir-navigation.diff
+}
+
+build() {
+ make -C "${_name}"
+}
+
+package() {
+ cd "${_name}"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ make -C icon PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 sxiv.desktop "$pkgdir"/usr/share/applications/sxiv.desktop
+}
+
+# vim:set ts=2 sw=2 et: