summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilip Parag2019-06-14 23:01:47 +0200
committerFilip Parag2019-06-14 23:01:47 +0200
commit044284f49aacaed6ca6706ab93ee288fd39ab884 (patch)
tree16f9d6226addcae27af03f503643a547f488e40f /PKGBUILD
parentea6092fd7c6c24591d18615bb2dbadff7d183b54 (diff)
downloadaur-044284f49aacaed6ca6706ab93ee288fd39ab884.tar.gz
pkgver fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a5843c2c323..a23cf56a0444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,23 +25,23 @@ md5sums=('SKIP')
validpgpkeys=()
prepare() {
- git clone $source "$pkgname-$pkgver"
+ git clone $source "$pkgname-git"
}
pkgver() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-git"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- chmod +x "$pkgname-$pkgver/sydf"
+ chmod +x "$pkgname-git/sydf"
}
check() {
- test -f "$pkgname-$pkgver/sydf"
+ test -f "$pkgname-git/sydf"
}
package() {
mkdir -p ${pkgdir}/usr/bin
- cp "$pkgname-$pkgver/sydf" ${pkgdir}/usr/bin
+ cp "$pkgname-git/sydf" ${pkgdir}/usr/bin
}