summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilip Parag2019-06-16 21:23:01 +0200
committerFilip Parag2019-06-16 21:23:01 +0200
commit67414472dd75e54cdbb2a7a1821113aed831f623 (patch)
tree8d1723f4ba7f5be5225f9a83df592e08e9a7b511 /PKGBUILD
parent81f14f8cfcdcdde733399e89ed56e4e5ef307e56 (diff)
downloadaur-67414472dd75e54cdbb2a7a1821113aed831f623.tar.gz
Git clone release branch only
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2ff7451d182..8d1d4cf40bb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,11 @@ md5sums=('SKIP')
validpgpkeys=()
prepare() {
- git clone $source "$pkgname-git"
+ git clone -b "$pkgver" --depth 1 "$source" "$pkgname-git"
}
pkgver() {
- cd "$pkgname-git"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ echo "$pkgver"
}
build() {