summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilip Parag2019-06-14 22:40:03 +0200
committerFilip Parag2019-06-14 22:40:03 +0200
commitc2a007a8e40bcbe58e2d973c742d397be74a4cad (patch)
tree41b086b5c3c61879083fdaca5d9019edaad50faa /PKGBUILD
downloadaur-c2a007a8e40bcbe58e2d973c742d397be74a4cad.tar.gz
Release 0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb93dbee7253
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Filip Parag <aur@filiparag.com>
+pkgname=sydf
+pkgver=0.1.r3.g527d662
+pkgrel=1
+epoch=
+pkgdesc="Symlink Your Damn Files"
+arch=(any)
+url="https://github.com/filiparag/sydf"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/filiparag/sydf")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ git clone $source "$pkgname-$pkgver"
+}
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ chmod +x "$pkgname-$pkgver/sydf"
+}
+
+check() {
+ test -f "$pkgname-$pkgver/sydf"
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ cp "$pkgname-$pkgver/sydf" ${pkgdir}/usr/bin
+}