summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsygnmdev2017-04-30 21:24:51 +0200
committersygnmdev2017-04-30 21:24:51 +0200
commit4370cc07f01f566b49091c05dd7da18d563a39b0 (patch)
tree31a2622c3ecff696963da4d009cd874fa9e2f4b7 /PKGBUILD
downloadaur-4370cc07f01f566b49091c05dd7da18d563a39b0.tar.gz
1.0.0alpha1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b67d7e5051
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: sygnmdev <sygnmdev at sygnm dot org>
+pkgname=sygnm
+pkgver=1.0.0alpha1
+pkgrel=1
+pkgdesc="Computer algebra system (currently pre-alpha)"
+arch=('i686' 'x86_64')
+url="https://sygnm.org/"
+license=('AGPL3')
+depends=('flint' 'arb' 'boost-libs' 'icu' 'gmp' 'qt5-base' 'readline' 'python' 'sqlite')
+makedepends=('boost' 'cmake' 'swig' 'python')
+source=("local://$pkgname-$pkgver.tar.gz")
+options=(debug !strip)
+conflicts=('sygnm-git')
+
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ cmake . -DCMAKE_BUILD_TYPE=Debug -DSYGNM_BUILD_ALL=On -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ cd sygnm-jupyter
+ python setup.py install --root="$pkgdir/" --optimize=1
+ cd ../sygnm/python
+ python setup.py install --root="$pkgdir/" --optimize=1
+}