summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEinar Lielmanis2019-08-16 09:42:39 +0300
committerEinar Lielmanis2019-08-16 09:43:55 +0300
commit3b5f1da2da8eab35153f05f9fdcf8ba54f978660 (patch)
tree6ff08ef4c5da4be5ab38158f86f59d26e01ffe92 /PKGBUILD
parent5e37f7ea1b2b15106e508ae43386aacd99a445ef (diff)
downloadaur-3b5f1da2da8eab35153f05f9fdcf8ba54f978660.tar.gz
Add SSL set_host_name patch to support SNI
https://sylpheed.sraoss.jp/redmine/issues/306
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2f32ad764a3..597296456e8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=sylpheed-beta
pkgver=3.7.0beta1
-pkgrel=3
+pkgrel=4
pkgdesc="Lightweight and user-friendly e-mail client. Latest official beta version."
arch=('i686' 'x86_64')
url="http://sylpheed.sraoss.jp/en/"
@@ -11,7 +11,10 @@ depends=('gpgme' 'gtk2' 'compface' 'gtkspell')
options=('libtool')
conflicts=('sylpheed' 'sylpheed-beta-iconmod')
provides=('sylpheed')
-source=(http://sylpheed.sraoss.jp/sylpheed/v3.7beta/sylpheed-$pkgver.tar.bz2{,.asc})
+source=(
+ http://sylpheed.sraoss.jp/sylpheed/v3.7beta/sylpheed-$pkgver.tar.bz2{,.asc}
+ ssl-sni-support.patch
+ )
build() {
cd "$srcdir/sylpheed-$pkgver"
@@ -21,6 +24,8 @@ build() {
sed -i 's:enchant/enchant.h:enchant-2/enchant.h:g' src/compose.c
sed -i 's:PKG_CONFIG --libs enchant:PKG_CONFIG --libs enchant-2:g' configure.ac
+ patch -p1 < "$srcdir/ssl-sni-support.patch"
+
autoconf
./configure --prefix=/usr --enable-ldap --enable-gpgme
make
@@ -35,4 +40,5 @@ package() {
validpgpkeys=('8CF3A5AC417ADE72B0AA4A835024337CC00C2E26')
md5sums=('21826a6096cc6feb732bdaeb87435435'
- 'SKIP')
+ 'SKIP'
+ 'b05b75bb2bd46d4022f920e09e0b1923')