summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2016-08-02 14:21:27 -0400
committerKevin MacMartin2016-08-02 14:21:27 -0400
commit51524dc6031015531b75becdc57efd38597fbe17 (patch)
treef262333a8b33b826aaf0379ac920241215ac27d2 /PKGBUILD
parentdf1dc1da3c1557588ed8eebdfe57bef36503be93 (diff)
downloadaur-51524dc6031015531b75becdc57efd38597fbe17.tar.gz
Update to 0.14.3 and keep the original binary name as the syncthing package installs the man page for stdiscosrv for some reason
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 10 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42ecca4cbaa5..5b8fbf06aa72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer : Kevin MacMartin <prurigro@gmail.com>
+_binname=stdiscosrv
_pkgname=syncthing
pkgname=$_pkgname-discosrv
epoch=1
-pkgver=0.13.10
+pkgver=0.14.3
pkgrel=1
pkgdesc='Discover server for the syncthing P2P synchronization utility'
url='http://syncthing.net'
@@ -19,43 +20,31 @@ source=(
"$pkgname.tmpfiles.conf"
)
sha512sums=(
- '199c38644a7e5d43777ca2e497d5304d8e77485d21aeed9a00efc74dd98bfb0c473dd0bf3230b8e1e9742315915419f198bb8d0a9b294d2f6fe918b6e0175812'
+ 'f9586013253ad031e1940e73f01f8ca398820e9ffeef0978fcd51079c535c04957c0be1314ecc635251ae06300c6b4141077ac5c3c8e7e9741d58e4545a7f3ba'
'b2a8daa48be57ad47542569473128c8590d4bbe124de0912ce5b3de7deb1b54dd0d3ed66e925fc11addded075d24d6a1fe822d71338d128b7ca03fd43c082d8c'
'28b0bb6a6f2fa536ec8cb887cfebf4706be25af5e29da39e2e3776daeeeb48f75fb5be255472920355948d8905830342866e89299facd626ddf8a658d84faf27'
)
build() {
- cd $_pkgname-$pkgver/cmd/discosrv
+ cd $_pkgname-$pkgver/cmd/$_binname
export GOPATH="$srcdir"
go get -d -tags purego
-
- case "$CARCH" in
- x86_64)
- export target='discosrv-linux-amd64'
- ;;
- i686)
- export target='discosrv-linux-386'
- ;;
- arm*)
- export target='discosrv-linux-arm'
- ;;
- esac
-
go build -i -v -ldflags -w
}
package() {
# Install systemd service and tmpfiles config
install -Dm644 $pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
- install -Dm644 $pkgname.tmpfiles.conf "$pkgdir"/usr/lib/tmpfiles.d/$pkgname.conf
+ install -Dm644 $pkgname.tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
# Install license and list of authors
cd $_pkgname-$pkgver
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 AUTHORS "$pkgdir/usr/share/licenses/$pkgname/AUTHORS"
- # Install documentation and binary
- cd cmd/discosrv
- install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm755 discosrv "$pkgdir/usr/bin/$pkgname"
+ # Install the man page
+ install -Dm644 man/$_binname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+
+ # Install the binary
+ install -Dm755 cmd/$_binname/$_binname "$pkgdir/usr/bin/$pkgname"
}