summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhill2017-06-12 20:42:06 +0800
committerhill2017-06-12 20:42:06 +0800
commitf4ab3f6b2de61566dae812f021ca80cd65ea7d5e (patch)
treef4b9713735142474442ee82fd1f848c61806d31b /PKGBUILD
parent855885c0d8ca2585406423c9cde15b86e375d2b2 (diff)
downloadaur-f4ab3f6b2de61566dae812f021ca80cd65ea7d5e.tar.gz
update to use gvt for vendor library; add aarch64 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49f75d766b47..098293114ae8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=syncthing-inotify-git
_pkgname=syncthing-inotify
-pkgver=0.7.r9.gef7839c
+pkgver=0.8.5.r24.gaf6fbf9
pkgrel=1
pkgdesc="Inotify file watcher for Syncthing"
url="https://github.com/syncthing/syncthing-inotify"
license=('MPL')
-arch=('i686' 'x86_64')
+arch=(any)
provides=("$_pkgname")
conflicts=("$_pkgname")
depends=('syncthing')
@@ -33,14 +33,11 @@ build() {
export GOPATH="${srcdir}"
cd "${srcdir}/src/github.com/syncthing/${_pkgname}"
go get
+ go get -u github.com/FiloSottile/gvt
+ ${srcdir}/bin/gvt update github.com/zillode/notify
go build
}
-check() {
- export GOPATH="${srcdir}"
- cd "${srcdir}/src/github.com/syncthing/${_pkgname}"
- go test
-}
package() {
cd "${srcdir}/src/github.com/syncthing/${_pkgname}"