summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2023-02-13 16:02:09 +0100
committerMartchus2023-02-13 16:02:09 +0100
commitee06a383e16efce93783e0fc8c221a05b4b4bca9 (patch)
tree12714e33f31d88f8c0fc83d76008b1a7cdbe48b7 /PKGBUILD
parent73c9c05e4fba252a2bdd2a1af00b39c0126de230 (diff)
downloadaur-ee06a383e16efce93783e0fc8c221a05b4b4bca9.tar.gz
Ensure HOME is set
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a2db06bef54..d3e6feb2c401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -74,6 +74,7 @@ build() {
check() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ export HOME=${HOME:-/} # https://github.com/syncthing/syncthing/issues/8785
QT_QPA_PLATFORM=offscreen SYNCTHING_PORT=$(ephemeral_port) SYNCTHING_TEST_TIMEOUT_FACTOR=3 ninja check
}