summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-09-16 19:53:40 +0800
committerChih-Hsuan Yen2022-09-16 19:53:40 +0800
commit10db1639d9d03ef0ed3a571c3eec309f28c2dfe2 (patch)
treec48af320da1a7a833c9ed2c41449e1b8dfc5cd3f /PKGBUILD
parent84b6550a97f26e2bf384aecfee5c43a03d212210 (diff)
downloadaur-10db1639d9d03ef0ed3a571c3eec309f28c2dfe2.tar.gz
change pkgver() and various fixes
Suggested at https://aur.archlinux.org/packages/synergy-git#comment-881788 * Fix dependency issues identified by namcap * curl is no longer needed https://github.com/symless/synergy-core/issues/6288 * libxkbfile is now directly used https://github.com/symless/synergy-core/pull/7114 * Enable debug * Disable auto-updating
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2fdb4b20a33..84e470442e6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,37 +11,34 @@
_pkgname=synergy
pkgname=$_pkgname-git
-pkgver=20211021.r4088.940e2ecd2
-pkgrel=2
+epoch=1
+pkgver=1.14.5.23.r0.g452c631d6
+pkgrel=1
pkgdesc='Share a single mouse and keyboard between multiple computers'
url='http://synergy-foss.org'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('GPL2')
provides=("$_pkgname")
conflicts=("$_pkgname")
-depends=('libxtst' 'libxinerama' 'libxkbcommon-x11' 'avahi' 'curl' 'libnotify' 'libxrandr' 'hicolor-icon-theme')
+depends=('libxtst' 'libxinerama' 'libxkbcommon-x11' 'libxkbfile' 'avahi' 'libnotify' 'libxrandr' 'hicolor-icon-theme')
makedepends=('libxt' 'cmake' 'qt5-base' 'gmock' 'gtest' 'git' 'qt5-tools')
checkdepends=('xorg-server-xvfb')
optdepends=('qt5-base: gui support')
+options=('debug')
source=(
"$_pkgname::git+https://github.com/symless/$_pkgname-core.git"
"${_pkgname}s_at.socket"
"${_pkgname}s_at.service"
)
-sha512sums=(
- 'SKIP'
- 'f9c124533dfd0bbbb1b5036b7f4b06f7f86f69165e88b9146ff17798377119eb9f1a4666f3b2ee9840bc436558d715cdbfe2fdfd7624348fae64871f785a1a62'
- 'e85cc3452bb8ba8fcccb1857386c77eb1e4cabb149a1c492c56b38e1b121ac0e7d96c6fcbd3c9b522d3a4ae9d7a9974f4a89fc32b02a56f665be92af219e371c'
-)
+sha512sums=('SKIP'
+ 'f9c124533dfd0bbbb1b5036b7f4b06f7f86f69165e88b9146ff17798377119eb9f1a4666f3b2ee9840bc436558d715cdbfe2fdfd7624348fae64871f785a1a62'
+ 'e85cc3452bb8ba8fcccb1857386c77eb1e4cabb149a1c492c56b38e1b121ac0e7d96c6fcbd3c9b522d3a4ae9d7a9974f4a89fc32b02a56f665be92af219e371c')
pkgver() {
cd $_pkgname
- printf "%s.r%s.%s" \
- "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {