summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattéo Delabre2020-01-28 20:06:05 +0100
committerMattéo Delabre2020-01-28 20:06:05 +0100
commit571c5e1824772e12f12cf3f6b3276a952ec013a1 (patch)
treebc565c0da6985de6092fa9b6e191721eae4f6d87 /PKGBUILD
parent9274e1d328c6a0d9772af31f7441dada74158ba2 (diff)
downloadaur-synfig.tar.gz
Fix template error and add missing dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc0549618a89..c476bd72d699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,39 @@
-# Maintainer: Mattéo Delabre <bonjour@matteodelabre.me>
+# Maintainer: Mattéo Delabre <spam@delab.re>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Franco Iacomella <yaco@gnu.org>
pkgname=synfig
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Professional vector animation program (CLI renderer only)"
arch=(x86_64)
url="https://synfig.org"
license=('GPL2')
depends=('libxml++2.6' 'libsigc++2.0' 'libmagick6' 'ffmpeg' 'fontconfig'
'libpng' 'libtiff' 'libdv' 'libmng' 'cairo' 'pango' 'boost-libs' 'mlt'
- 'fftw' 'intltool')
+ 'fftw' 'intltool' 'sdl' 'sdl_mixer' 'sdl_image')
makedepends=('boost')
optdepends=('openexr' 'libsigc++')
source=(
"https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/source-ETL-$pkgver.tar.gz"
"https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/source-$pkgname-$pkgver.tar.gz"
- 'ffmpeg-3.0.patch')
+ 'ffmpeg-3.0.patch'
+ 'savecanvas-template.patch')
sha256sums=(
'0dc19c5a6c9e964054ca3af6dacd6ab0c198d78071cfab2aebac178afe454d8b'
'5f5f7b33483041165f9a63fe4d95eb815971c7444569e574206f6964e83cc2ef'
- '424b3cc38809038c3b015ce2a6d3a006d73aefe0445d0090fae45e8eb69b2b55')
+ 'SKIP'
+ 'SKIP')
prepare() {
# Workaround usage of deprecated ffmpeg constants by manually defining
# them, and other deprecation workarounds
cd "$srcdir"/$pkgname-$pkgver
patch -p1 -i "$srcdir"/ffmpeg-3.0.patch
+
+ # Fix invalid template inside “extern” C block
+ patch -p1 -i "$srcdir"/savecanvas-template.patch
+
}
build() {