summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe2018-01-03 11:34:49 +0100
committerFelipe2018-01-03 11:34:49 +0100
commitaadc30b270e1d346cb58df908224a3e7da5013dc (patch)
tree75047dfd1b91037defb170bec71f4b7f6c7c0580 /PKGBUILD
downloadaur-aadc30b270e1d346cb58df908224a3e7da5013dc.tar.gz
1.0.0-10240
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7573fa02d71b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Felipe Martin <me@fmartingr.com>
+
+pkgname=synology-drive
+pkgver="1.0.0"
+pkgrel="10240"
+pkgdesc="Drive for PC, the desktop utility of the DSM add-on package, Drive, allows you to sync and share files owned by you or shared by others between a centralized Synology NAS and multiple client computers."
+arch=('i686' 'x86_64')
+url="http://www.synology.com"
+license=('unknown')
+depends=('glibc' 'libsm' 'binutils' 'fontconfig')
+optdepends=('nautilus: For nautilus integration')
+conflicts=('cloudstation-beta', 'cloudstation-3.0', 'cloudstation-drive')
+source=()
+md5sums=()
+
+source_i686=(https://global.download.synology.com/download/Tools/SynologyDriveClient/1.0.0-10240/Ubuntu/Installer/i686/synology-drive-10240.i686.deb)
+md5sums_i686=('4512b72de1dcb87b38cb312d821c6b53')
+
+source_x86_64=(https://global.download.synology.com/download/Tools/SynologyDriveClient/1.0.0-10240/Ubuntu/Installer/x86_64/synology-drive-10240.x86_64.deb)
+md5sums_x86_64=('f76c60432d219c9ec434d2261c5b6eb4')
+
+prepare() {
+ cd "$srcdir"
+ mkdir control data
+ ar x synology-drive-*
+ tar xf data.tar.gz --directory data
+}
+
+package() {
+ cp -r "$srcdir/data/opt" "$pkgdir/opt"
+ cp -r "$srcdir/data/usr" "$pkgdir/usr"
+} \ No newline at end of file