summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-06-22 13:51:53 +0300
committerCaleb Maclennan2020-06-22 13:51:53 +0300
commit1a88cc3fb55b87e4823479e272e7eaa01b10b18e (patch)
tree6b7f36cc3771740521a0598f44299ac7ba144158 /PKGBUILD
downloadaur-syntha-font.tar.gz
Initial upload: syntha-font 1.008-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5745074268fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_font=syntha
+pkgbase=$_font-font
+pkgname=("ttf-$_font")
+pkgver=1.008
+pkgrel=1
+pkgdesc='A rounded display typeface inspired by vintage synthesizer abbreviations'
+url="https://www.neogrey.com/portfolio/$_font"
+arch=('any')
+license=('custom:FFPU')
+makedepends=('hq')
+source=("$_font-$pkgver.zip::https://dl.dafont.com/dl/?f=${_font/-/_}"
+ "font-licenses.html::https://www.neogrey.com/font-licenses")
+sha256sums=('8d159c26bb3e98d186f66c1f5c02bbed93bd3c8dd7bb3dce489d1518de7442dc'
+ 'SKIP')
+
+prepare() {
+ hq article text < font-licenses.html > FFPU.txt
+}
+
+package_ttf-syntha() {
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" FFPU.txt
+}