summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNobbele2020-02-20 01:23:54 +0100
committerNobbele2020-02-20 01:23:54 +0100
commit08334e3de0806e9edcbc3b39f6ab15e1c04dc0ac (patch)
tree7fbe058bb012e7b524a0ab23c4240fa235f187cd /PKGBUILD
downloadaur-08334e3de0806e9edcbc3b39f6ab15e1c04dc0ac.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a15af4b1db6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nobbele <realnobbele@gmail.com>
+
+pkgname=synthv-editor
+pkgver=108
+pkgrel=1
+pkgdesc="Synthesizer V at the Forefront of Singing Synth"
+arch=("x86_64")
+url=https://synthesizerv.com/download
+license=(custom)
+depends=()
+provides=("synthesizerv")
+conflicts=("synthesizerv")
+source=("https://s3-ap-northeast-1.amazonaws.com/synthesizerv-download/synthv-editor.zip"
+ "synthesizer-v-editor.sh")
+sha256sums=("SKIP"
+ "SKIP")
+
+build() {
+ chmod +x "${srcdir}/synthv-editor/synthesizer-v-editor"
+}
+
+package() {
+ install -d "${pkgdir}/opt/synthv-editor"
+ cp -r "${srcdir}/synthv-editor/." "${pkgdir}/opt/synthv-editor"
+
+ install -Dm755 "${srcdir}/synthesizer-v-editor.sh" "${pkgdir}/usr/bin/synthesizer-v-editor"
+}