summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNyaacinth2022-06-03 21:44:54 +0800
committerNyaacinth2022-06-03 21:44:54 +0800
commit67f339576bd264f03fed99c8ae573510e50ec4f1 (patch)
tree7b2568c0e302f500c84c5284ea6c0379da8b3c2b /PKGBUILD
parent81b30f1cd70f675d6f3b254d5e4056325b4a9202 (diff)
downloadaur-synthv-studio-bin.tar.gz
Update to 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c909bfe18544..504d0442e4ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Nyaacinth <nyaacinth_liota@outlook.com>
pkgname=synthv-studio-bin
-pkgver=1
+pkgver=2
pkgrel=1
pkgdesc="Synthesizer V studio by Dreamtonics"
arch=("x86_64")
url="https://dreamtonics.com/synthesizerv"
license=(custom)
-depends=()
+depends=("xdg-utils")
provides=("synthv-studio")
conflicts=()
source=("synthv-studio.sh"
"synthv-studio.png"
- "synthv-studio.desktop")
-sha256sums=("83a419a9c281fbca976bc683ba584a7e0bf4ac5cc249c3a0ed0cfff92f2215af"
+ "synthv-studio.desktop"
+ "info.txt")
+sha256sums=("d9489e2e8a3c75e84e8d5a8c9eade3a68657f0f88e70899363882e456a7c1c48"
"f0f0180bbd5a029655089c5f8d5948c093622dd978e8aa6a4c47689b5936351b"
- "710f95ca38ab0e69c0431feb7f323bf84b4b4b822248a465ed5e525b36070871")
+ "710f95ca38ab0e69c0431feb7f323bf84b4b4b822248a465ed5e525b36070871"
+ "912bc157e0bbebae3ff646c1f57cad7701be20759281c15e75fc201a46085e5c")
package() {
- read -p "Please input the path to your Synthesizer V Studio distribution (the zip file you downloaded) on the filesystem: " SVDIST
- install -Dm644 "${SVDIST}" "${pkgdir}/opt/synthv-studio/dist.zip"
- install -Dm644 "${srcdir}/synthv-studio.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/synthv-studio.png"
- install -Dm755 "${srcdir}/synthv-studio.sh" "${pkgdir}/usr/bin/synthv-studio"
- install -Dm755 "${srcdir}/synthv-studio.desktop" "${pkgdir}/usr/share/applications/synthv-studio.desktop"
+ install -Dm644 "${srcdir}/info.txt" "${pkgdir}/opt/synthv-studio/info.txt"
+ install -Dm644 "${srcdir}/synthv-studio.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/synthv-studio.png"
+ install -Dm755 "${srcdir}/synthv-studio.sh" "${pkgdir}/usr/bin/synthv-studio"
+ install -Dm755 "${srcdir}/synthv-studio.desktop" "${pkgdir}/usr/share/applications/synthv-studio.desktop"
}