summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-01-07 12:31:09 -0700
committerMark Wagie2022-01-07 12:31:09 -0700
commit7e4ae4cbe572e31b6a345b7c3b11e9538b532a2c (patch)
tree3dbbcf33b5faa1f77080d131d69d16c0435ea80a /PKGBUILD
parent68c339c5b29d25d7b8c40f671aea8852e5abcdbf (diff)
downloadaur-7e4ae4cbe572e31b6a345b7c3b11e9538b532a2c.tar.gz
minor PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02b1ec3f0764..d15dad44ae03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,25 +12,25 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('95d18be01c83bc529ad4311a5c59507d0e1568160638d9823b6c02aa6261c7e8')
prepare() {
- export GOPATH="$srcdir/gopath"
- go clean -modcache
+ export GOPATH="$srcdir/gopath"
+ go clean -modcache
}
build() {
- cd "$pkgname-$pkgver"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -v .
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -v .
- # Clean mod cache for makepkg -C
- go clean -modcache
+ # Clean mod cache for makepkg -C
+ go clean -modcache
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}