summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÓscar García Amor2023-04-10 14:04:47 +0200
committerÓscar García Amor2023-04-10 14:04:47 +0200
commita3d43da5d2be78f34559e81c297d26585449c62c (patch)
treef52c061de065ba93ba9ac51819dcf09f71074787 /PKGBUILD
parent24c5ab20d67f110471b7bb2f03b91cac63c78c73 (diff)
downloadaur-sysdweb.tar.gz
upgpkg: sysdweb 1.1.5-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91d00656c11e..1d642594ce21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=sysdweb
-pkgver=1.1.3
+pkgver=1.1.5
pkgrel=1
pkgdesc='Control systemd services through Web or REST API'
arch=('any')
url='https://github.com/ogarcia/sysdweb'
-license=('GPL')
-depends=('python-bottle' 'python-dbus' 'python-pam' 'python-setuptools' 'python-systemd')
-makedepends=('python-setuptools')
+license=('GPL3')
+depends=('python-bottle' 'python-dbus' 'python-pam' 'python-systemd')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
backup=("etc/${pkgname}.conf")
-source=("https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('abdaa501d00837c9335828cc03b202374c19e5033199c6bd6a60dc4849d90b3c')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('ab0ecea40c93a31ce6bf5f594d7fc6c948ae2debb5482e341bfd5323fc712d2e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
cd "${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize='1'
+ python -m installer --destdir="${pkgdir}" dist/*.whl
# config file
install -D -m644 "${pkgname}.conf" \