summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-04-17 20:34:53 -0600
committerMark Wagie2023-04-17 20:34:53 -0600
commit59c3ebfc727cc53504bafd68b7822d933d07db7c (patch)
tree6155e8af5728229feb4095a94562354a46d51f3a /PKGBUILD
parentda8e3d0ab49b262978ff202b739f3d7a61cd47b4 (diff)
downloadaur-59c3ebfc727cc53504bafd68b7822d933d07db7c.tar.gz
add kudu support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46b6fe23ab03..6d85741d8127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
pkgname=system76-dkms
-pkgver=1.0.13
-pkgrel=2
+pkgver=1.0.13+2+g78ede46
+pkgrel=1
pkgdesc="On newer System76 laptops, this driver controls some of the hotkeys and allows for custom fan control."
arch=('x86_64')
url="https://github.com/pop-os/system76-dkms"
license=('GPL2')
depends=('dkms')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('5d491180786faef804da71da9b08090ab902e1cf6f52070115c65fb7546a3376')
+makedepends=('git')
+_commit=78ede46c30f3bdb38d6acec5bc3fe982703ade17
+source=("git+https://github.com/pop-os/system76-dkms.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/-/+/g'
+}
package() {
- cd "$pkgname-$pkgver"
- local install_dir="$pkgdir/usr/src/system76-$pkgver"
+ cd "$srcdir/$pkgname"
+ local install_dir="$pkgdir/usr/src/system76-${pkgver//+*/}"
# Install source files
for file in {Makefile,*.c,*.h}; do
@@ -25,7 +32,7 @@ package() {
install -Dm644 lib/udev/hwdb.d/*.hwdb -t "$pkgdir/usr/lib/udev/hwdb.d/"
# Edit and install dkms configuration
- sed "s/#MODULE_VERSION#/$pkgver/" "debian/$pkgname.dkms" > "$install_dir/dkms.conf"
+ sed "s/#MODULE_VERSION#/${pkgver//+*/}/" "debian/$pkgname.dkms" > "$install_dir/dkms.conf"
# Load the module at boot
install -Dm644 "usr/share/initramfs-tools/modules.d/$pkgname.conf" \