summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 15:08:05 -0700
committerMark Wagie2024-01-21 15:08:05 -0700
commit64aed5e0a37aaadac4c2e15a4632bccb07253340 (patch)
tree5dd10690950e982f666990ce5377ca9b95d146dd /PKGBUILD
parentc16cc5f75d4587918c9b66edf09872643f3159c2 (diff)
downloadaur-system76-dkms-git.tar.gz
use SPDX license identifier
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8a161c9a8d5..1398c86395c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Co-Maintainer: Tony Lambiris <tony@libpcap.net>
# Contributor: Shaleen Jain <shaleen(at)jain(dot)sh>
pkgname=system76-dkms-git
@@ -7,7 +7,7 @@ pkgrel=1
pkgdesc="On newer System76 laptops, this driver controls some of the hotkeys and allows for custom fan control."
arch=('x86_64')
url="https://github.com/pop-os/system76-dkms"
-license=('GPL2')
+license=('GPL-2.0-or-later')
depends=('dkms')
makedepends=('git')
provides=("${pkgname%-git}")
@@ -16,13 +16,13 @@ source=('git+https://github.com/pop-os/system76-dkms.git')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
package() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${pkgname%-git}"
local install_dir="$pkgdir/usr/src/system76-${pkgver//.r*/}"
# Install source files