summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2022-05-05 01:29:11 -0400
committerTony Lambiris2022-05-05 01:29:11 -0400
commit399129037583393fc6a147b28c9c8152ec539656 (patch)
tree4618d499300db337c7662ba8d8e06f59d6529e8d /PKGBUILD
parent8cbbc919b26d6996b5df2e7141d8af78c8ba9bee (diff)
downloadaur-399129037583393fc6a147b28c9c8152ec539656.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da0acac54ce7..2bfaed0b1d94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Tony Lambiris <tony@libpcap.net>
# Contributor: Shaleen Jain <shaleen(at)jain(dot)sh>
pkgname=system76-dkms-git
-pkgver=1.0.13.r0.g68bd479
+pkgver=1.0.13.r2.g78ede46
pkgrel=1
pkgdesc="On newer System76 laptops, this driver controls some of the hotkeys and allows for custom fan control."
arch=('x86_64')
@@ -16,12 +16,13 @@ source=('git+https://github.com/pop-os/system76-dkms.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${srcdir}/${pkgname%-git}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${srcdir}/${pkgname%-git}"
local install_dir="$pkgdir/usr/src/system76-${pkgver//.r*/}"
# Install source files