summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorConrad Haupt2020-07-15 12:37:22 +0200
committerConrad Haupt2020-07-15 12:37:22 +0200
commitb056fd2ef6943708129b6a0902836b325b891fe2 (patch)
tree64bee590f669e6d5c7a3b33fbddf2db83a5dd769 /PKGBUILD
downloadaur-b056fd2ef6943708129b6a0902836b325b891fe2.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b29e910dff1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: NeedleNardleNoo (conrad@conradhaupt.co.za)
+pkgname=systemd-asus-battery-threshold
+pkgver=1.1
+pkgrel=2
+pkgdesc="Systemd service that manages the Asus Zenbook charging threshold. Specifically designed for the Zenbook 15 UX533."
+arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+# url="https://github.com/Jguer/yay"
+license=('MIT')
+depends=(
+ 'systemd'
+ 'linux>=5.4'
+ 'git'
+)
+source=("asus-charging-threshold"
+ "asus-charging-threshold.path"
+ "asus-charging-threshold.service")
+sha256sums=('6442bc26a7c562f5afe6467dab36365c709909f6a81afcecfc0c25cff0f1bab0'
+ 'c1389fd887fecbcb2799fa37ddd956b2dacb7bc1da78d44898578986cd79615e'
+ '1709bc93a1c4dff8068b270d0515d99627bebb3a9c19dd5950eb687bc24c4e9e')
+
+package() {
+ install -v -D -m644 "${srcdir}/asus-charging-threshold.service" "${pkgdir}/etc/systemd/system/asus-charging-threshold.service"
+ install -v -D -m644 "${srcdir}/asus-charging-threshold.path" "${pkgdir}/etc/systemd/system/asus-charging-threshold.path"
+ install -v -D -m644 "${srcdir}/asus-charging-threshold" "${pkgdir}/etc/asus-charging-threshold"
+ mkdir -p "${pkgdir}/usr/lib/systemd/system/multi-user.target.wants/"
+ ln -s "${pkgdir}/etc/systemd/system/asus-charging-threshold.path" "${pkgdir}/usr/lib/systemd/system/multi-user.target.wants/asus-charging-threshold.path"
+} \ No newline at end of file